Recherche sur le site

Qui est en ligne

10 utilisateur(s) en ligne (5 membre(s) connecté(s) sur Articles)

Membre(s): 0
Invité(s): 10

Plus ...
Vous étes ici » Accueil » Forums » Problème avec la personnalisation de x_movie [Forums - Demande]





Problème avec la personnalisation de x_movie
Visiteur_
Salut,

J'ai essayé d'appliquer ton explication Avelo pour personnaliser le module x_movie seulement les fichiers à  modifier ne sont pas la même et la logiciel n'éxiste plus à  la version que tu as mise !

Mon site : http://netsaka.com

Est ce que tu peux me donner un coup de pouce pour modifier "tpl_player.php" voici la source du fichier :


//FLV Player
}elseif (preg_match("/".$xoopsModuleConfig['flvp_type']."/i", $movietype)) {

$player = '
<script type="text/javascript" src="./js/CreateObjectEmbed.js"></script>
<script type="text/javascript">
<!--
CreateFlvObj(
"'.$url.'",
"'.$logourl.'",
"logo.png",
"'.$xoopsModuleConfig['flashobjectwidth'].'",
"'.$xoopsModuleConfig['flashobjectheight'].'"
);
//-->
</script>
<noscript>
<object classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/sh ... flash.cab#version=8"
width="'.$xoopsModuleConfig['flashobjectwidth'].'" height="'.$xoopsModuleConfig['flashobjectheight'].'"
id="theMediaPlayer">
<param name=movie value="mediaplayer.swf">
<param name=quality value="high">
<param name=bgcolor value="#FFFFFF">
<param name=allowFullScreen value="true">
<param name=swLiveConnect value="true">
<param name=allowScriptAccess value="sameDomain">
<param name="FlashVars" value="file='.$url.'&width='.$xoopsModuleConfig['flashobjectwidth'].'&height='.$xoopsModuleConfig['flashobjectheight'].'&displaywidth='.$xoopsModuleConfig['flashobjectwidth'].'&overstretch=fit&autostart=true&shuffle=false&image='.$logourl.'&logo=logo.png&backcolor=0xFFFFFF">
<embed type="application/x-shockwave-flash"
pluginspage="http://www.macromedia.com/go/getflashplayer"
width="'.$xoopsModuleConfig['flashobjectwidth'].'" height="'.$xoopsModuleConfig['flashobjectheight'].'" bgcolor="#FFFFFF"
name="theMediaPlayer"
src="mediaplayer.swf"
flashvars="file='.$url.'&width='.$xoopsModuleConfig['flashobjectwidth'].'&height='.$xoopsModuleConfig['flashobjectheight'].'&displaywidth='.$xoopsModuleConfig['flashobjectwidth'].'&overstretch=fit&autostart=true&shuffle=false&image='.$logourl.'&logo=logo.png&backcolor=0xFFFFFF">
</embed>
</object>
</noscript>
';
/******************

Posté le : 14/12/2008 23:25
Transférer la contribution vers d'autres applications Transférer


Re: Problème avec la personnalisation de x_movie
Webmestre
Inscrit:
25/07/2004 22:16
Messages: 1174
Salut , efectivement le lecteur à  changé et la nouvelle version ne fonctionne pas avec les parametres que j'avais mis.

La version 2.13 n'a jamais fonctionné chez moi , j'ai essayé plusieurs fois de l'installer mais ca ne fonctionne pas , je vais doncavoir du mal à  t'aider...

Sinon tu peux toujours copier mon lecteur flv pour tester chez toi , en prenant soin de faire une sauvegarde du tient avant http://www.avelo.net/modules/x_movie/flvplayer.swf (clic droit enregistrer sous .....

edited : Albatroxm13 dans un message precedent sur le forum avec la meme version que toi nous a posté ca , edite les ligne

//FLV Player
      
}elseif (preg_match("/".$xoopsModuleConfig['flvp_type']."/i"$movietype)) {

    
$player '
        <script type="text/javascript" src="./js/CreateObjectEmbed.js"></script>
        <script type="text/javascript">
        <!--
        CreateFlvObj(
          "'
.$url.'",
          "'
.$logourl.'",
          "logo.png",
          "'
.$xoopsModuleConfig['flashobjectwidth'].'",
          "'
.$xoopsModuleConfig['flashobjectheight'].'"
        );
        //-->
        </script>
        <noscript>
    <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
    codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8"
    width="'
.$xoopsModuleConfig['flashobjectwidth'].'" height="'.$xoopsModuleConfig['flashobjectheight'].'"
    id="theMediaPlayer">
    <param name=movie value="mediaplayer.swf">
    <param name=quality value="high">
    <param name=bgcolor value="#FFFFFF">
    <param name=allowFullScreen value="true">
    <param name=swLiveConnect value="true">
    <param name=allowScriptAccess value="sameDomain">
    <param name="FlashVars" value="file='
.$url.'&width='.$xoopsModuleConfig['flashobjectwidth'].'&height='.$xoopsModuleConfig['flashobjectheight'].'&displaywidth='.$xoopsModuleConfig['flashobjectwidth'].'&overstretch=fit&autostart=true&shuffle=false&image='.$logourl.'&logo=logo.png">
    <embed type="application/x-shockwave-flash" 
    pluginspage="http://www.macromedia.com/go/getflashplayer" 
    width="'
.$xoopsModuleConfig['flashobjectwidth'].'" height="'.$xoopsModuleConfig['flashobjectheight'].'" bgcolor="#FFFFFF" 
    name="theMediaPlayer"
    src="mediaplayer.swf"
    flashvars="file=$url&showdigits=true&autostart=true&logo=avelo2.png&link=http://www.avelo.net/modules/x_movie/list.php" />"; </embed>
    </object>
    </noscript>
    '
;


dans ce message là  http://www.avelo.net/modules/newbb/vi ... php?topic_id=503&forum=10

Posté le : 15/12/2008 12:29
Transférer la contribution vers d'autres applications Transférer



 Haut   Précédent   Suivant



Vous pouvez voir les sujets.
Vous ne pouvez pas débuter de nouveaux sujets.
Vous ne pouvez pas répondre aux contributions.
Vous ne pouvez pas éditer vos contributions.
Vous ne pouvez pas effacez vos contributions.
Vous ne pouvez pas ajouter de nouveaux sondages.
Vous pouvez voter en sondage.
Vous ne pouvez pas attacher des fichiers à vos contributions.
Vous ne pouvez pas poster sans approbation.

[Recherche avancée]


Connexion

Identifiant :

Mot de passe :

Se souvenir de moi



Mot de passe perdu ?

Inscrivez-vous maintenant !